EEA to UK calling

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 10:30 UTC

Identified

Calling to the UK using EEA / EU caller ID is currently unavailable due to operational reasons.
We are working on addressing the operational issues with our upstream carrier for this route, it could take some time and we have no ETA.

It's likely to take at least 24 hours for an update on progress, we apologize for any inconvenience caused.

This does not affect calls to the UK with UK caller ID.
Posted Nov 17, 2025 - 12:11 UTC
This incident affected: Voice Network - Call Center Routes (United Kingdom) and Voice Network - Local Operator Conversational Routes (United Kingdom).