UK Calling Incident

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 14:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 17, 2025 - 14:19 UTC

Investigating

We are investigating call failures within the UK.
Further update to follow in the next 5 minutes.
Posted Nov 17, 2025 - 14:13 UTC
This incident affected: Voice Network - Call Center Routes (United Kingdom) and Voice Network - Local Operator Conversational Routes (United Kingdom).