Verification is currently underway for the maintenance items.
Posted May 02, 2025 - 09:19 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 02, 2025 - 08:25 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 02, 2025 - 08:23 UTC
Scheduled
We are performing some emergency maintenance on the PBX servers, whilst we don't expect any issues as a result of this maintenance task, it should be noted that the system will be under heavier load whilst this task is performed and therefore we consider the service to be at risk during the maintenance window.
Posted May 02, 2025 - 08:22 UTC
This scheduled maintenance affected: PBX Features (EU Region, US Region).