Intra EEA calls

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 15:38 UTC

Identified

Some users calling intra EEA (between European countries from EU caller ID) may be experiencing intermittent no audio, premature call drops or one way audio.

The issue lays with one of our upstream partners and they are working to mitigate this as soon as possible.

We shall provide a further update soon.
Posted Aug 07, 2026 - 15:11 UTC
This incident affected: Voice Network - Local Operator Conversational Routes (Austria, Belgium, Bulgaria, Croatia, Cyprus, Czech Republic, Denmark, Estonia, Finland, France, Germany, Greece, Hungary, Iceland, Ireland, Italy, Latvia, Liechtenstein, Luxembourg, Lithuania, Malta, Netherlands, Norway, Poland, Portugal, Romania, Slovakia, Slovenia, Spain, Sweden, United Kingdom) and Voice Network - Call Center Routes (United Kingdom).