At 2:17 PM BST on Sat Jul 26, 2025, EE and BT issued the following update: "Latest update: Following a further fix overnight to a technical fault impacting voice calls on our network, we’ve been monitoring the situation throughout the day and services have been running as normal. We continue to conduct enhanced monitoring to prevent recurrence. We sincerely apologise for any inconvenience this issue has caused."
A review of calls placed over the weekend show calls to those networks have reached normal success rates so we're considering this incident resolved.
Posted Jul 26, 2025 - 14:30 UTC
Update
Whilst we've found no official statement or acknowledgement from EE & BT at this time, many providers are reporting issues reaching numbers on all UK networks.
User driven downdetector.co.uk is showing elevated reports from users on all networks experiencing problems with calling.
We believe the issue lies with EE and BT only, however due to the way number porting works in the UK, users on other networks with numbers ported from EE's network are affected too as are calls to EE numbers from other networks.
In relation to BT, it seems to be users who've been migrated to BT Digital Voice that are experiencing call failures both inbound and outbound.
The messages/errors you will see on these calls seems to be varying as time passes, we see sometimes 408 Request Timeout, other times 500 Service Unavailable and randomly every number rings out busy for a few moments. Bottom line, if you're getting strange or unexpected failures when calling a mobile in the UK, it's likely to be related to this issue. In the case of landlines, we've saw some reports online by customers of BT that users calling their numbers are getting at times disconnected number messages
As we saw yesterday, both EE and BT were slow to acknowledge and update the public about the issues on their network, but with this now spanning 2 days and impacting the entire UK we see little option other than for them to provide a statement soon.
As soon as we find anything, we'll post it here.
Posted Jul 25, 2025 - 12:04 UTC
Investigating
We are seeing an increase in 408 Request Timeout and 500 errors to calls on EE & BT networks in the UK again. Downdetector in the UK is also showing elevated issue reports from their customers.
We're investigating and will provide a further update as soon as possible.
Posted Jul 25, 2025 - 09:58 UTC
This incident affected: Voice Network - Call Center Routes (United Kingdom) and Voice Network - Local Operator Conversational Routes (United Kingdom).