CRM Timeouts

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 15:00 UTC

Update

Service has been restored but is considered at risk. We continue to work on this as a priority.
Posted Jul 14, 2026 - 10:06 UTC

Identified

We have identified the cause and are working on a solution.
Posted Jul 14, 2026 - 09:54 UTC

Investigating

We are investigating timeouts on the CRM platform as a matter of urgency.
Posted Jul 14, 2026 - 09:52 UTC
This incident affected: CRM Hosting (Frontend Application).