UK - EE/BT & Vodafone Outage

Incident Report for J Murray Solutions

Resolved

EE issued an update at 21:21 BST saying:

"Following a technical fault impacting voice services on our network earlier today, we have now resolved the problem and the service is running as normal. We sincerely apologise and recognise the inconvenience this may have caused."

We are closing this incident
Posted Jul 24, 2025 - 20:30 UTC

Update

We are seeing a marignal increase in calls going through successfully to the EE & BT network giving hope that the end of the outage is on the horizon.

We're seeing in the last 15-20 minutes however that the success rate of call attempts to the Vodafone network has fallen dramatically to the point only around 1 in 10 calls are going through. (They too have been experiencing issues all day, but it seemed to initially only affect outbound calls from the Vodafone network or cross network calls, most of our calls from our network were making it through).

Vodafone haven't issued any acknowledgement we're aware of about the issues with their network today, however their team seems to be using the same "reach out to us via DM to check this out" canned response to their customers reporting it on social media.

Since the working day has ended for most of our clients calling the UK, we'll update this only once the issue has been resolved or there has been a significant change in the circumstances.
Posted Jul 24, 2025 - 17:00 UTC

Update

A spokesperson for BT & EE has apologized saying the firm was "currently addressing an issue impacting our services. We're currently working urgently to fix this issue and will provide a further update as soon as possible."

We'll post again when new information becomes available.
Posted Jul 24, 2025 - 15:07 UTC

Update

Upon further inspection, the issue with some of the other networks other than EE and BT is that numbers ported from these networks to other networks are affected by the outage, this means that calls to numbers originally not belonging to those networks appear to be working normally.

Stats from the last 30 minutes or so show 100% failure rate for calls to numbers on the EE network. Taking ported numbers out of the equation, calls to mobile numbers on Vodafone, Three and O2 show normal connection rates.

Overall connection rates have improved and we're seeing wait time come down for dialer users, we're working to suppress numbers on the EE network from dialing lists temporarily to help improve this further for our hosted dialer clients.
Posted Jul 24, 2025 - 13:54 UTC

Update

The issue has spread and is affecting every network in the UK. Media reports seem to confirm a major UK telecoms outage.

We are seeing hugely elevated call failures to UK numbers, this means when dialing UK numbers you will likely see errors such as 408 Request Timeout or 5XX code with a variable message.

For dialer users, this means at best massively increased wait times between calls and at worst a complete lack of calls.

This issue is outside our control, and there's unfortunately no way for us to mitigate it's impact but we'll do our best to get the latest information posted on here as soon as we get it.
Posted Jul 24, 2025 - 13:28 UTC

Update

EE, BT and Vodafone are all experiencing issues and calls to these networks may fail.

Dialer users on UK campaigns will be seeing increased wait times as a result of this and manual dialled calls may fail with either 408 Request Timeout or a 5XX message.
Posted Jul 24, 2025 - 13:09 UTC

Identified

The EE network in the UK have been experiencing issues since this morning but it appears to be getting worse with increased reports of failed calls to numbers on their network.

You may experience issues dialing numbers on EE and BT networks as a result and dialer users on UK campaigns are starting to see increased wait times.

We will post any further information we get as and when we get it.
Posted Jul 24, 2025 - 13:05 UTC
This incident affected: Voice Network - Call Center Routes (United Kingdom) and Voice Network - Local Operator Conversational Routes (United Kingdom).