As of 7.45 UTC, around 90% of the mainland's power has been restored.
We are witnessing however some internet outages persisting in the Canary Islands via the main fiber provider Movistar/O2. This could impact remote workers' ability to obtain a stable enough connection for the dialer.
It may be busier than normal this morning, we therefore ask for your patience if reaching out.
Posted Apr 29, 2025 - 08:05 UTC
Update
As work continues on the mainland to restore power, here in the Canary Islands, we're seeing telecommunications networks starting to fail. Out of 4 connections, we only have one currently working and it's too slow to perform any meaningful tasks at present.
Due to the slow speeds, phone lines have been closed until the situation improves and live chat may take longer to answer/go unanswered, we apoligize for any inconvenience this may cause.
Posted Apr 28, 2025 - 19:11 UTC
Update
An update has been issued by Red Eléctrica saying that they are beginning to restore supply en the North and South of the peninsula. No ETAs have been issued for specific areas.
We are still unaffected entirely.
Posted Apr 28, 2025 - 11:40 UTC
Identified
The majority of the mainland of Spain has lost power along with parts of France and Portugal. We appear to still have full internet connectivity but we are not ruling out a loss of connectivity. Most of our clients in Spain have lost connection to our systems, this is not a fault on our part as all services are up and running.
Information is not available from the distributor about the cause yet, their site seems to be partly down where the faults are reported.
If we get any updates, we will post them here providing we don't experience any internet connectivity issues.
Posted Apr 28, 2025 - 11:04 UTC
This incident affected: JMS Support (Phone Support, Email / Ticket Support, Live Chat Support).