US and Canada Outbound Calling

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 17:40 UTC

Monitoring

Hi all,

Between 11.45am and 12.02pm Eastern Standard Time there was an infrastructure outage affecting our interconnection with some upstream carriers in the US and Canada.

This was resolved by the responsible party whilst we were investigating the cause of the call failures. We are monitoring for any further issues.
Posted Feb 24, 2025 - 17:03 UTC
This incident affected: Voice Network - Call Center Routes (Canada, United States).