Monitoring systems are showing the service is up again and the data center have confirmed they completed the recovery.
Tickets held up by this involving data loading and customizations to CRM systems blocked by asset storage being unavailable will be worked throughout today therefore we'll be monitoring this very closely.
We are planning the maintenance window during which we will migrate the data away from this provider to an alternative with a better track record on redundancy and uptime history. This change will also involve a secondary provider being added and data replicated in both removing the single point of failure that currently exists.
We apologize for the inconvenience and thank you for your patience.
Posted Aug 26, 2026 - 07:14 UTC
Update
The data center have issued an update.
There's been two consecutive hardware failures in short succession which resulted in automatic recovery and redundancy failing. They are in the process of manually restoring it, but to do so this means they have had to stop all services relating to the affected S3 storage until it's completed. They are aiming to have the full restore completed by tomorrow August 26th at 11.00 CEST (10am UK/Canary Time). We'll send a further update as soon as one becomes available or by tomorrow at 10am, whichever comes first.
We have already set up alternative data storage ready to migrate to when it's available again, the current S3 storage provider will be phased out as a matter of urgency since this marks the 6th outage this month and around the 26th so far this year.
Posted Aug 25, 2026 - 15:13 UTC
Update
Adding another item to the list:
Due to a hardware fault at the data center, S3 storage is currently in a degraded state which may cause errors for the following:
- Client Area: Error when uploading attachments to a ticket, or trying to access attachments from a ticket. - Support Tickets via Emails: The ticket is created but without the attachments, we'll grab these from the mailbox as necessary. - Support call voicemails: The voicemails are failing to save, but we still get notification of the call and calls will be returned generally within the hour. - CRM File Attachments: Errors accessing or uploading attachments on CRM systems. This will include email attachments on mailboxes connected to your CRM instance. - Bulk Data uploads to CRM: Since the CRM systems use S3 storage for files, it's not currently possible to bulk upload data on most CRMs. Creating individual leads are not affected, importing from CSV is. - Archived call recording access: On some high volume systems with an archive policy, archived call recordings may be unavailable whilst this outage lasts.
Posted Aug 25, 2026 - 12:49 UTC
Identified
Due to a hardware fault at the data center, S3 storage is currently in a degraded state which may cause errors for the following:
- Client Area: Error when uploading attachments to a ticket, or trying to access attachments from a ticket. - Support Tickets via Emails: The ticket is created but without the attachments, we'll grab these from the mailbox as necessary. - Support call voicemails: The voicemails are failing to save, but we still get notification of the call and calls will be returned generally within the hour. - CRM File Attachments: Errors accessing or uploading attachments on CRM systems. This will include email attachments on mailboxes connected to your CRM instance. - Archived call recording access: On some high volume systems with an archive policy, archived call recordings may be unavailable whilst this outage lasts.
Posted Aug 25, 2026 - 12:18 UTC
This incident affected: JMS Support (Phone Support, Email / Ticket Support), Client Area, and CRM Hosting (Frontend Application).