Support Live Chat Issues

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 20:16 UTC

Investigating

We are currently having difficulties accessing chats on the live chat platform.

For non urgent requests, please email support@jmurraysolutions.com

For urgent technical issues, you should reach out on the following numbers:

US 646-647-8850
MX 55 9990 3550
CA 613-900-6456
ES 922 937 384
UK 01324 285022
Posted Jul 04, 2025 - 16:50 UTC
This incident affected: JMS Support (Live Chat Support).