Contact Issues via WhatsApp

Incident Report for J Murray Solutions

Update

We're currently awaiting a number port completing today between 10:00 UTC and 12:00 UTC, once complete we should be able to restore access.

Remember the official contact methods in the meantime:

Live Chat: via the system you're accessing or on the client area or website: https://portal.jmurraysolutions.com/

Phone:
United Kingdom: 01324 285022
España: 922 93 73 84
United States: 646 647 8850
Canada: 613 900 6456
México: 55 9990 3550

Email:
support@jmurraysolutions.com
Posted Mar 25, 2025 - 09:43 UTC

Identified

We are currently having issues with WhatsApp and are unable to access chats.
Tenemos problemas en acceder al WhatsApp y no podemos ver los chats.

Please address any issues via live chat on your system or via our website, or by calling via one of the normal numbers (not via WhatsApp).
Si tienes alguna incidencia o problema con un sistema, por favor pongas en contacto con nosotros a través el chat en el sistema o por teléfono tradicional en los siguientes números.

United Kingdom: 01324 285022
España: 922 93 73 84
United States: 646 647 8850
Canada: 613 900 6456
México: 55 9990 3550

You may also send non urgent communications to support@jmurraysolutions.com or go to the client area to raise a ticket.
Tambien puedes crear un ticket en la área de clientes o correo electrónico support@jmurraysolutions.com

Client Area / Área de clientes: https://portal.jmurraysolutions.com/
Posted Mar 21, 2025 - 17:18 UTC