Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 22, 2026 - 18:00 UTC
Scheduled
We will be performing scheduled maintenance on the telephony engine that underpins the PBX platform.
During this maintenance window, users of CRM Webphone, MicroSIP, Zoiper, Desk Phones, and Teams Direct Routing will be unable to make or receive calls and may see registration errors. JMS Support will also be unavailable via phone during this period.
To minimise disruption, maintenance has been scheduled outside of normal business hours, as usage is typically very low after 5pm on Fridays.
Before the upgrade begins, we will perform a controlled shutdown of services. This process will initially prevent new calls from being established while allowing any active calls to complete. Once all in-progress calls have ended, the platform will be taken offline to complete the upgrade.
This maintenance is required to apply a critical security update to the platform infrastructure.
Posted May 21, 2026 - 16:15 UTC
This scheduled maintenance affected: JMS Support (Phone Support), PBX Features (EU Region, US Region), and Voice Network Infrastructure (Microsoft Teams Direct Routing).