JMS Support Calls

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 22:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 24, 2025 - 21:40 UTC

Update

This is affecting calls from +1 countries, not just the US.
We are investigating the cause.
Posted Nov 24, 2025 - 21:38 UTC

Investigating

We are investigating reports of calls failing to get through to JMS Support from the US.
Posted Nov 24, 2025 - 21:36 UTC
This incident affected: JMS Support (Phone Support).