UK Calling Issues

Incident Report for J Murray Solutions

Resolved

This incident has been resolved.
Posted May 08, 2025 - 11:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2025 - 11:51 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 08, 2025 - 11:50 UTC

Investigating

We are investigating a spike in failed calls to the UK via our dialer routes. Further update to follow within 5 minutes.
Posted May 08, 2025 - 11:40 UTC
This incident affected: Voice Network - Call Center Routes (United Kingdom).